Jump to content
Sign in to follow this  
tsmsoccer

Track Call and Power Relay

Recommended Posts

I have a Relay, and Track Call button connected to a Arduino Board in Race Coordinator

The Relay works fine turning power on and off at the start and end of heats and correctly cuts the power at the end of the race. I am running version 1.14.0.0 of the software in Race Coordinator.

The problem occurs when I pause a race either through the Call Button or through the space bar on the computer. When I pause the race the power is cut to the track all good so far but when I resume the race the countdown commences and race starts but the relay is not tripped back on. There is no power to the track.

The only way I can get the power back on is while the race is paused go to Race Coordinator on the computer and click Turn Power on. Power is returned to the track. I then click on either hit the Track Call button or the space bar computer the countdown resumes and race continues normally. 

The Master Relay is connected to the Arduino on the digital side of the board but I have also tried connecting the pins on the analogue side of the board but with the same effect.

I have tried the Invert Relay option but that does not work if fixing the problem.

The main issue with having to turn the power back on manually after a Track Call is that power is activated to the track prior to the countdown for the restart and drivers can move their car forward prior to the countdown for the time remaining recommencing 

Tks

Charlie

Share this post


Link to post
Share on other sites

Hi Charlie

I seem to recall this being a problem with all the local tracks using the Arduino set up at one stage, luckily i was not included in the roll out but i do know that it was sort of fixed at Marios (maybe) and i think John had something to do with it, send him or Lawrence a pm and see if they can remember what they did.

I still use, and will continue to use the old 25 pin printer port connection,  it has not missed a beat in 15 years. 


Quickly read this post before it is deleted or i turn grey again

Gary

http://www.facebook.com/Rallyproxy2017

Share this post


Link to post
Share on other sites

Yep Gaz I like the old 25 pin port unfortunately modern computers no longer include the port. I will send a message to John see if he remembers anything 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...