Jump to content
slotbaker

Website Help Needed...

Recommended Posts

I'm hoping that someone here might be able to help me with a problem that has occurred on a car club website that I created many years ago, and still maintain.

 

It has been working faultlessly up to now, and I'm not smart enough to fix it! :(

 

A bit of background;

- I'm self-taught, and use the now outdated MS Frontpage program for editing.

- I'm a member of the car club, and I'm the voluntary webmaster.

- The site is hosted by Crazy Domains.

- The website address is studebakercarclubnsw.com

- I'm not a programmer.

 

So, about 5 days ago I casually went to the website and the home page opened momentarily, then changed to an all-white page with the single word "undefined" appearing in the top left corner.

 

At first, I couldn't get to get to any other part of the sight, but I tried opening the site again and was able to click on a menu button before the screen went white, and was able to open up other pages OK.

I was able to get back to the home page as normal, so the site is working as it should, except fot the initial visit.

I've since found out that refreshing the screen takes it back to the home page.

 

I had no clue on what that meant, so I logged into the account and reset the password (thinking it may have been hacked) and uploaded the index page again, but didn't fix it.

 

I tried using a 5 year old version of the index page, but the problem was still there.

 

Thinking there might be a problem on the hosting side, I raised the issue with Crazy Domains and they were help full, but concluded that there was no issue from their side and reported back;

"It is guaranteed that the error is in the scripting in the index.html web page."

 

My search on dr. google pointed me in a few directions, but I was unable to work it out.

:huh:

Thanks,


Steve K.

Share this post


Link to post
Share on other sites

I opened the site and navigated through a few pages without any issue. I am using a Mac with Safari and I tried it on Chrome as well.

 

What operating system are you using and which browser ? - Microsoft Explorer, Chrome, Firefox? It could be an issue with your browser.

 

I would suggest downloading a different browser if you haven't already.

 

I ran it through a website checker - but you may not want to go there - it came up with 262 errors - though the majority are because it uses older html code instead of CSS - so no big deal or urgent need to fix.

 

cheers

DM

Edited by dangermouse

Share this post


Link to post
Share on other sites

Hi, thanks for responding.

 

I have Explorer, Chrome, and Firefox loaded on Windows 10 PC (not Mac) and it occurs with all 3.

 

Only difference I've noticed is that Explorer doesn't refresh back to the home page like Chrome and Firefox does.

:huh:

Edited by slotbaker

Steve K.

Share this post


Link to post
Share on other sites

Slotbaker, I will pm you my email address for you to send over the html files.

It works okay on Firefox on my PC but the error shows up on my iPad

 

A couple of other things I noticed - each link from the main page opens a new tab

Wouldn't it be better to have the menu bar on all pages and simply flick page to page without opening new tabs?

 

There doesn't appear to be any css style sheet at all, so the text looks a bit ordinary.

 

Anyway, I can have a look at that for you, if you don't already have a better offer.

Share this post


Link to post
Share on other sites

Hi Slots, Many thanks for responding, yes, I'm not sure why the menu options open in a new tab. They didn't originally, and not sure why it changed.

:huh:


Steve K.

Share this post


Link to post
Share on other sites

Steve,

 

The issue is related to your page counter, on initial request it is returning the undefined, it appears to be complaining of incomplete data (that is what the base64 response is returning).

 

Subsequent requests are fine.

 

Looking at the first time the page is loaded and subsequent requests:

 

- The first request to generate the counter has an additional query parameter: get_config=true which appears to cause the counter request to sit there forever (and eventually causes the undefined).

 

Without looking at the source code it would be hard to advise any further, if you wanted to send over the home page source, I'd be more than happy to have a look

 

You can easily recreate the issue by opening an incognito tab, loading the website, receiving the undefined, refreshing the page, rinse and repeat.

 

Mark

Edited by miveson

Share this post


Link to post
Share on other sites

That explains the intermittency of the issue

thought it was something else and that I had sorted it until Steve said he still had the issue

was about to have another poke

Mark you’re the pro, can I leave with you?

i was also going to give Steve a version with the menu bar on all pages, and had hacked out some script code for target = blank to stop the new tabs opening

have a look here I did first few pages only

www.burmac.nz/Studebaker

Share this post


Link to post
Share on other sites

The issue is related to your page counter, on initial request it is returning the undefined, it appears to be complaining of incomplete data (that is what the base64 response is returning).

 

Mark, thanks for responding.

PM sent.


Steve K.

Share this post


Link to post
Share on other sites

Success....

 

Many thanks to SlotsNZ and miveson for helping me with this little drama.

 

Mike I. created the fix, and it works beautifully.

 

And thanks to Auslot for being here.

 

I couldn't have done it on my own.

:)


Steve K.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...