Jump to content
Anthony G

Uk Vs Aus Sets

Recommended Posts

Just wondering what the problems I would face by buying from the UK with the difference of the power points? I am looking at getting a Scalextric 6 car powerbase and a 4 car powerbase set. Is it wise to just use an adaptor for our power points or even replace the UK plug for one of our own?

Share this post


Link to post
Share on other sites

Hi Anthony,

 

If you get just the 6 car Advanced Powerbase (APB) you wont get the power supplies anyway, they are sold individually, usually around $100 ea here in Oz. Apparently you can use Toshiba Laptop power supplies (about $15ea on Ebay) but I can't tell you which ones to get. Keep away from the 4 car power base if possible and stick to the APB. I purchased my APB from the UK a few years ago now with no problems whatsoever but if I was to go digital and was starting again I'd purchase the Scalextric Digital Platinum set for sure, everything you need is in the box to start with, APB, 6 Controllers, 6 cars with digital chips, 2 power supplies etc, try sourcing all these parts individually and adding them up, cost you double.

 

Matt

Share this post


Link to post
Share on other sites

Thanks Matt. Its just that I can get the triple cup game and a 6car power base for about half the price of the digital platinum set. I already have the extra chips I purchased from the USA, its just that have told me that they do not suggest that I just use an adaptor altho they have said it would be my own choice. I am just wondering why they have said this. I realise I would need an extra power supply to run the 6 cars and I will look into getting the Toshiba power supply for the 2nd.

Share this post


Link to post
Share on other sites

Stick with power supplies of the same type, don't mix and match, either go with the 2 Scaley psu's or 2 Toshiba Laptop psu's, you wouldn't want your new APB to go pop and void warranty because you used a mix of psu's, you will void any warranty using adaptors or the Toshiba psu's anyway.

 

Get what deal best suits your needs, don't rush into it, have a good look around at what you can get and for how much.

 

cheers

 

Matt

Share this post


Link to post
Share on other sites

If the issue is the plugs on the UK power packs - you could get an electrician to change the plug for you (or do it yourself but I didn't tell you that) - pretty sure the UK uses 240v as well

Edited by dangermouse

Share this post


Link to post
Share on other sites

Yes, the 4 car PSU is the same as the 6 car PSU's...

 

The Toshiba Power supplies needs to be the 15v 5a one...

Share this post


Link to post
Share on other sites

So what everybody is saying is that it would be fine to just change the plug from the UK type with no problems? I realise I would need to by another power source to run 6 cars but can I get away with just 1 to run 4 cars?

Edited by Anthony G

Share this post


Link to post
Share on other sites

One power supply will only run a maximum of 3 cars.

 

The APB support analogue mode so you can run non-digital cars (without lane changing etc). With one power supply you will only be able to power a single lane.

 

The reason I mentioned the 4 car PB, is that you may be able to pick it up cheaply.

 

Share this post


Link to post
Share on other sites

So the 1 power supply will only run 3 cars on a single lane? So how does the 4 car APB version in the UK get away with only supplying 1 power supply?

Edited by Anthony G

Share this post


Link to post
Share on other sites

Let me clarify:

 

1 power supply will power either 3 x digital cars both lanes or if you set the APB in to analogue mode it will power a single lane.

 

The 4 car pb might say it can power 4 cars, but in reality you'd be lucky get to 3 digital cars running well on it. Hence the reason why the 6 car pb and APB was developed.

 

Mark

Share this post


Link to post
Share on other sites

Will the other lane still work in analogue? I am guessing it will just not give a readout on the screen? Sorry I am new to all this stuff. It does not matter so much as I will be purchasing another pb, my biggest worry that I was asking was whether I can still run the UK pb by just changing the plug and they are 240v like us

Share this post


Link to post
Share on other sites

Hi again,

 

With the one psu plugged into the APB you will get no power to the rails on the 2nd lane in analogue mode.

Can't help you with changing the plug on the UK psu, can't see why it wouldn't work though.

And like Mark has said in a previous post the 4 car digital psu will work with the APB, all you will need then is another psu of the same type, well worth the investment having the 2 psu's.

 

Matt

Share this post


Link to post
Share on other sites

If you are worried about changing the plug, you could always go to you local $2 shop and buy a Aus/Uk power adaptor.

Share this post


Link to post
Share on other sites

Hi guys and girls. Got delivery of my digital track, albeit with only the 1 power supply and it is a lot of fun. So thank you all for you help, it makes a lot more sense to me now that I have played with it.

Share this post


Link to post
Share on other sites

Glad it all worked ok and that you like it...

 

I absolutely love my 6car powerbase, even though it spends 90% of it's time in analog mode...

Share this post


Link to post
Share on other sites

I must admit I am the same atm with only the 1 power supply, mainly due to the fact I have a few very tight corners that tend to slow the pacer down ( alho at 50 -75% it makes t a fairly close race ) Pee'd off atm as I seem to have done some damage to the cogs on my gulf Mac 12c by wedgng it into a small barrier and it is now reving like mad but going nowhere! Was my fastest car before this!

Share this post


Link to post
Share on other sites

Check your rear axle, as it's not uncommon for them to get dislodged in an accident...

Alternatively, check the motor for the same reason...

 

I'm starting to get into the habit of hot gluing every motor in, and any axle bushing that's not tight gets glued across the top too...

Share this post


Link to post
Share on other sites

Check to see if either of the gears are spinning on their shafts.

If they are a drop of superglue will help.


A man without a woman is like a neck without a pain.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...