Jump to content
Sign in to follow this  
Keith

Sports Track Issue

Recommended Posts

Hi guys, i am having trouble with my sports digital track, it is kept clean, it works great for the most part, one lane is super fast and the other is about 60%, you can fly around when all of a sudden it goes slow for a certain distance and then off it goes again, i have taken it apart, replaced sections, and checked joints, i really do not want to start soldering wire to it and i obviously do not need to fit jumpers as it only affects a small area always on the same side, does any one have any suggestions, i am aware that i can turn it over and squash each joint to supposedly make better contact, but i have also heard this can damage it as well, i dont want to run copper tape as i may want to change the lay out.

Share this post


Link to post
Share on other sites

Keith,

 

Buy yourself a Multimeter $5 at Jaycar and you'll easily find the areas of the track that are giving you the trouble, you can try and fix or simply buy a new piece. I had very similar issues but was able to identify with the multimeter a couple of track pieces that would on occassion cause issues, replaced and vola, everything good. Whilst your there get yourself some inox and give the rails a good wipe down - you'll be surprised at the difference it will make (careful not to put any on the track as the lubricant will cause all manner of slides.

 

Mark

Share this post


Link to post
Share on other sites

I actually do have a multi metre, not exactly sure how to read it but i will give it a go thanks, i do have INOX already and have kept it clean.

Share this post


Link to post
Share on other sites

Jumpers is the best solution, dodgy connections can be a nightmare to solve. At the world record scalextric speed trial a few years back the scalextric rep had a home made tool for tweaking all the joints - a bit like a wide flat screwdriver that he twisted at each end of the track. He still had about 10 jumpers as well.


gallery_4291_493_4007.jpg

.............................PM me for C7042 Aux to PC cables............or Pit-Pro...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...