Jump to content
Race Coordinator

Race Coordinator Digital (For Ssd)

Recommended Posts

Hi Dave just testing with scorpius controller and im not getting a response All working fine with ssd controller, remove that change to scorpius in driver

setup ,update and car id 1 pin 1 id 1 for controller but no movement.

cheers glen

 

scratch that dave it works in race no fuel, and race but not in practice mode.

Edited by glengtl1

www.gtlslotcaraccessories.com

Share this post


Link to post
Share on other sites

I'll need to look into this. Practice is a funny thing, but I don't see why it would be any different than a real race..

 

Hi Dave just testing with scorpius controller and im not getting a response All working fine with ssd controller, remove that change to scorpius in driver

setup ,update and car id 1 pin 1 id 1 for controller but no movement.

cheers glen

 

scratch that dave it works in race no fuel, and race but not in practice mode.

Share this post


Link to post
Share on other sites

Hi Dave Had some more time to play today i created a race and i was unable to run with scorpius controller In my race ,and also still unable to run in practice. it works when i just use ssd controller attached to apb. hope that helps

cheers

Glen


www.gtlslotcaraccessories.com

Share this post


Link to post
Share on other sites

I don't actually have an SSD setup to test on but I know this works. At least for a "real" race. Looking over the code (it's been awhile), here's a few things to try:

  1. Remove the Scorpius dongle and start your race. If you DO NOT get an error message saying it can't communicate to the track (or something like that) it means you're not configured properly. RCD requires you to let it know you want to use the Scorpius controllers. Otherwise it would have to try and find the dongle every time for anybody out there. Not good. You tell it you want to use the Scorpius controllers by having one or more drivers configured with "3rd Party Controller" option set to Scorpius. At least one driver with this setting set must be in the race or I won't initialize the dongle. If ANY driver has it set, any driver can use a scorpius wireless controller.
  2. Assuming that is your issue. Try this with both Practice and a "real" race. Practice is special in that real drivers aren't in the race. So there's an off chance it doesn't work in which case I'll have to look into it.

If these are your issues, I'll have to rethink how I enable the support. I wanted it as simple as possible. Basically once I know you have a dongle I look for it. If I get data from the controller I use it over the plugged in controller, but I have to know to initialize the dongle...

 

Hi Dave Had some more time to play today i created a race and i was unable to run with scorpius controller In my race ,and also still unable to run in practice. it works when i just use ssd controller attached to apb. hope that helps

cheers

Glen

Share this post


Link to post
Share on other sites

Dave, Scorpius Controllers dont work in Practice mode as like you said real drivers are not in practice. What i do notice is though you need to have 1 driver at least selected in the main menu for Practice to work if i have a driver in that list that has a scorpius controller assigned to them practice mode will not function any driver that is selected in that list must be assigned to a wired controller, even though the UI in practice mode only shows the 6 ID's as names and not real drivers names.

  • Upvote 1

Check out North Brisbane Slotcar Racing: http://northbrisslots.forumotion.com

Share this post


Link to post
Share on other sites

John,

 

Are you saying that if a driver has the use scorpius controller set and is in the Current Driver List when you run practice, that nobody can count laps? Do you get an error message saying RCD can't communicate to the track?

Share this post


Link to post
Share on other sites

Okay, I'm going to do some code diving and will send you a build. I know at least partially what's going on. I sent you an email...

 

Dave, no error message just loads up the screen, cars don't move only way to get it to work is to remove the scorpius driver from the list

Share this post


Link to post
Share on other sites

Haha. Welcome back (:

 

Yes, this is in theory fixed, but I haven't released the build yet. I'm waiting to hear how things went with John and then very likely will be releasing version 1.0 shortly after. More information soon.

 

-Dave

Share this post


Link to post
Share on other sites

Laugh you may! I can't catch a break at the momment, i was playing around with RCD yesterday arvo and cleared out cars and drivers and put some of my cars in and drivers

all good, then i removed the races to set up some of my own, problem is now RCD crashes on me on bootup. Help me!!!!!!!!!!!, i reinstalled but same problem.

 

cheers Glen


www.gtlslotcaraccessories.com

Share this post


Link to post
Share on other sites

Congrats! I think you found the longest standing bug in the software to date. This particular issue has been there since day 1 (about 2 years ago). Unfortunately that probably doesn't make you feel any better.

 

The bug was triggered when you deleted all the races from the system. There's a small little crash that happens when you do that (as you've seen).

 

There are few options to fix the bug. First, you can delete your rc.db file (see the FAQ on my website for how to move RC from computer to computer) and then re-install the software. This will revert your database and undo the problem that's crashing you. Unfortunately you'll lose anything you've already setup if you do this so you'll have to recreate your cars, drivers, track setup, etc..

 

You could send me your rc.db file and I can fix it for you which would preserve your other settings. What I'd do is simply create a race for you in the DB that after you setup your races you'd just delete.

 

Finally you can wait for the new release. Unfortunately there's a fairly important bug I'm investigating in the current release so I can't give you a time frame on it other than "As soon as I possibly can"

 

Let me know what you decide to do, and sorry about that crash. I actually haven't seen a crash in the software in a very long time (experimental beta releases aside).

-Dave

Share this post


Link to post
Share on other sites

I will just delete and reinstall as i was only testing so not much info to put back in, Im liking your software with all the audio call outs ,I might have to have two tracks, 1 ssd and 1 Scorpius ,thanks Dave ( just checking ghost cars run ok !Yes nothing i should know about.?

 

cheers

Glen


www.gtlslotcaraccessories.com

Share this post


Link to post
Share on other sites

Ok reset and running, i am having trouble with 2 things 1st(getting to the end of a race without the race freezing but i can still initiate a yellowflag and countdown but no laps or fuel being counted or used. when it happens is at different times,2nd Scorpius controllers are very iratic in that the signal seems to lag getting to the car and end up shooting of

the track. , Would having the Scorpius software on the same pc be a dramma ?

cheers

Glen


www.gtlslotcaraccessories.com

Share this post


Link to post
Share on other sites

I dont think the Scorpius software will have anything to do with it, i have noticed some lag and and am also having an issue with the cars taking off using the scopius controller, i thought it might have been my PC and was about to reformat it this weekend but now that you have said that you have the same issue i will have to get Dave to have a look at it. Also sounds like that RCD is losing connection to your PC during a race, just one quick question how long are you using it before it stops counting laps? And if uninstalling and putting newer versions on are you fully deleting the old version and deleting the old Database before installing a new Version as i have had a similar issue when i have updated versions but atm seemed to have fixed it by doing a full uninstall and then going and deleting the old Database, i had a pacecar doing a 2 hour race last nite with no issue.

 

John

Edited by Johnsxr8

Check out North Brisbane Slotcar Racing: http://northbrisslots.forumotion.com

Share this post


Link to post
Share on other sites

HI John just finished exactly that and have just run a 20 lap fuel race with no hicups other than a very calm lady telling me i have 5 sec and ten sec left on lap 12. I to was starting to think my pc but i think not .(the time frame for the freeze i was having was variable shortest was 4 laps longest was 15laps, hopefully gone now)

Since doing the new reload when i nominate Scorpius and go to race it gives me a message of lost connection with track . which it didnt do to me yesterday.

planning on more testing tonight.

cheers

Glen


www.gtlslotcaraccessories.com

Share this post


Link to post
Share on other sites

Nice, the new version that Dave releases in the next couple of days has a totally different Scorpius setup where you select 3rd party controllers in Track setup and no matter what race you are in if you unplug your wired controller the scorpius controller takes over but as soon as you plug back in your wired controller it disables the wireless controller and the wired controller resumes control which is much easier and it also allows them to be used in the practice race mode.

 

John


Check out North Brisbane Slotcar Racing: http://northbrisslots.forumotion.com

Share this post


Link to post
Share on other sites

Glen,

 

1) Are you running lap based races or time based races? If lap based, you have to remove the audio callouts and create your own. RCD only comes with time based call outs and the races I provide by default are configured with them. If you used one of these races as a template to create a new lap based race, you'll get very whacky callouts

 

 

2) As John mentioned, in the new beta (not released yet) I moved the Scorpius setup into the SSD configuration. When I post the beta there will be more details but what it means is that the Scorpius controllers will work in practice mode unlike before.

 

3) John's been testing the newest build. My thoughts right now are to release it as a beta and if you're willing you can give it a shot. I'll setup the build with debug logging so when things happen you'll be able to send me logs and with any luck I'll be able to tell what's going on.

 

 

Thoughts?

-Dave

Share this post


Link to post
Share on other sites

Hi Dave sorted out the wacky callouts and set up my own and have run quite a few lap races and set up event with same races and testing tonight, all seems to be good

I found 1 quirk in track setup where you set yellowflag buttons and i ticked brake + lanechange + 0 throttle and just brake for pit stop and the yellow flag/restart go nuts in the race and it keeps trying to restart but only gets to 4 and then starts agian, it doesnt do it when the throttle is not ticked so easy to fix

Im Thinking i may have found a system that suits me to a T

Yes im happy to give the beta a run and see how it goes

 

cheers

Glen


www.gtlslotcaraccessories.com

Share this post


Link to post
Share on other sites

Glad to hear it Glen. Yeah we're still working out some of the kinks but it's getting there. From what I can tell it's very usable, just need to sort some minor things out. I was considering changing how the yellow flag stuff works anyway, so I'll look into the issue you're seeing at the same time. Once I've gone through it I'll get a beta build posted and let you know where it is. The new build will have the Scorpius controller setup changed and some other minor fixes. I'll need you (and others) to run it and send me the logs when you experience lag or any other weird things like that. More details will follow. Hopefully I'll have the build ready tonight or tomorrow.

 

-Dave

Share this post


Link to post
Share on other sites

Okay, I posted a new beta release on my website. It's version 0.2.1.80. This build has an attempted fix for some ghost car lane changing issues and I put in some more debug information into the logs for the scorpius controllers. So when you install this build if you have perceived lag with the controller or any other problems for that matter, please quit the application and send me the logs. The logs are located in your program data folder (see my website FAQ for how to move RC from one computer to another for the folder location). If you send me that entire folder it's guaranteed that I have what I need, but at very least I need all the txt files in that top level folder. Also note, that every time you start a race the logs are wiped out so if you have a problem, at very least copy the logs immediately so you can send them to me later. When reporting an issue, be as specific as you can be. Email the logs to me at "contact@racecoordinator.net"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...